Article 25. To Post a Book on Your Website

Books usually belong to 2 types of arrangement:
• Type 1: books that consist of only chapters. Chapters are normally
numbered. Some books use titles instead of chapter numbers. For example,
a book of poems, a short story collection. Some books use both numbers
and titles.
• Type 2: books that are organized into parts and chapters. Each part contains
several chapters. This arrangement is normally used with long novels and
research documents.
We will practice posting both types of books.
Your website must already have a category for books before you can post a
book. If your website hasn’t had such a category, please add a “Books”
category. Refer to “Article 3. To Add a Category to the Website” for
instructions.
Remember to choose “Tree Book” as the Content Type when you add the
“Books” category. You may name it “Novels”, “Fictions”, or any other name.
In this example, we name it “Books” for simplicity.
1. Add the category “Books”
• Login the Control Panel. Go to “Website Manager” and select
“Categories” in the drop down list.
• Select the appropriate Language Site. In this example, we will add the
“Books” category for the English site. If the box near the upper left corner
does not show “English Site”, click on it and select “English Site”.
• Click “Record Edit” near the upper right corner to add a record.
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• Click the box for “Parent” and select “Left Menu” to add this category to
the Left Menu.
• Fill in the “Title” box with “Books”.
• In the “Content Type” section, click the round button for “Tree Book”.
• In the “Page Interface” section, select the interface that you like. We will
select style 5 for this category.
• To decide how books are listed in the website, use the “Edit page layout”
button. Review to “Article 15 – To Change the Display of an Article List”
for more information.
• Click the “Add” button.
• However, our task is not done yet. You still need to place this new category
in order on the Left Menu. This can only be done after the category has
already been added. In the “Properties” section near the upper right corner,
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find the “Order” box. Click on it and select “After Writings”. This
category will be placed after “Writings” on the Left Menu.

• Next, click the “Update” button at the top or bottom of the record to finish.
You’ve just added the “Books” category to the website. Now, you can start
posting a book.
Here is an overview of steps:
-

-

Add a book title, which means adding a record for the book. Go to
“Content Manager” => “Books” => “Record Edit” => “New” then fill
in the title of the book, then “Save”.
Add chapters to the book. Note that adding chapters is completely
different from adding articles. Go to “Content Manager” => “Books”
=> “Data View” => “View Book Content” => “Record Edit” =>
“New”, then fill in the content of the chapter => “Save”.

Following are the steps in details.
2. Add a book title
• Go to “Content Manager” and select “Books” in the dropdown list.
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• The list of existing books in the website will appear. This list is now empty.

• Click “Record Edit” near the upper right corner. A new record will appear.
In this example, we will fill in the “Title” box with “Hon Buom Mo Tien”.
Fill in the “Author” box with “Nhat Linh; Khai Hung”. Note that you
should use a semicolon to separate the 2 authors. Check the box
corresponding to category “Books”. Our book record looks similar to this.

• You can leave the “Description” box empty, or you can fill in some
introduction of the book, or you can insert the image of the book cover. In
this example, we will insert a scanned image of the book cover. Refer to
“Article 8 – To Insert a Picture into an Article” for instructions.
• If you have a summary of the book, fill it in the “Brief” box.
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• You may also want to show a thumbnail image of the book in the list page.
In that case, you can upload the scanned image of the book cover, in any
size, to the web server. Click the “Browse” button at the end of the
“Thumbnail Image” box and do would usually do. Refer to “Article 8 – To
Insert a Picture into an Article” for instructions.
• Click the “Add” button to finish this step.
3. Add chapters to the Type 1 Book
A book should be shown with a table of contents to let viewers jump to any
chapter in the book. Therefore, adding chapters is completely different from
adding articles to the website. We will use the special button under each book
(in the list) to add a chapter to the book. Here’s how to do it.
• Go to “Content Manager”, then click on “Books” in the dropdown list

• The list of books will appear. At this moment, we’ve already had one book
title, “Hon Buom Mo Tien”. Right under the title and the summary, there is
a special button name “View book content”.

• Click this button. The list of chapters will appear. It is empty at this
moment.
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• Click “Record Edit” near the upper right corner. You will see a blank
record for a new chapter.
• “Title” box. Fill in with the title of the chapter. Most books use numbers for
chapter titles, for example, “Chuong 1”, “Chuong 2”, etc. Some books use
both numbers and titles, for example, “Chuong 1 – Ve Duoi Mai Nha”. In
this case, you may enter briefly “Chapter 1” in the Title box, and put the
title “Ve Duoi Mai Nha” in the Description box, together with the text.
• “Description” box. Fill in with the text for this chapter.
• “Choose Tree” box. Select which part of the book this chapter is related to.
At this moment, you would see “Hon Buom Mo Tien” in this box. Keep it
as is.
Here’s the reason why this box is named “Choose Tree”. A book may be
divided into parts and chapters. Each part contains several chapters. The
book structure is similar to a tree. The book title or the book itself is like the
tree trunk. Each part is like a branch. Each chapter is like a twig or a leaf.
When you add a chapter, you must tell which a part of the book it directly
belongs to.
• “No Link” box. Leave it as unchecked. This box is checked if this record is
the starting point of a part in the book.
The “No Link” box is usually checked for the first page of a part when a
book is arranged into parts and chapters.
• “Author” box. Fill in with the author of the chapter or the book, otherwise
the author’s name will not be shown at the top of this chapter.
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• Click the “Add” button to finish adding this chapter. The message “Data
Added Successfully” will appear at the upper left corner.

• Next, we will add the next chapter. Click the “New” button to start a new
record and repeat the previous steps.
•

Continue adding chapters until the end of the book.
NOTE: The web page will display chapters in the order that you add them.
Therefore, you should add chapters in their order in the book. If you skip
one chapter in the process, it is recommended that you redo from that
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chapter on. You may use the “Ordinal” and “Posted Date” boxes to change
the order in such case, but it is very time consuming.

• Suppose your book contains 3 chapters and we have finished adding them.
Let’s go to your website to check. Click the menu item “Books”. The page
will look like this.

• Click the thumbnail image; the page will look like this.

On the left is the book cover image. On the right is the table of contents
with 3 chapters.
• Click “Chuong 1”, you will see the text of chapter 1. The table of contents
is always shown at the upper right.
WEBSITE ADMIN GUIDE – PART II (v. 2.5)

Page 277

• You have finished adding a Type 1 book to the website.
4. To add chapters to the Type 2 Book
Type 2 Book is a book which contains Parts and Chapters. “Part” is the
starting point of a section which consists of several chapters. Part may be just
a page with the part number. It may also have a title. Some book may also
have a summary along with part number and part title.
In this example, we will post the book “Muon Nen Nguoi” by Pham Cao
Tung to the website. This book contains a Foreword (“Loi Noi Dau”) and 2
Parts. Part I consists of 4 chapters and Part II consists of 7 chapters.
Suppose we’ve already added the book title “Muon Nen Nguoi” in the
category Books. We added the book title the same way we would have done
with the Type 1 Book.
Now, we will add the parts and chapters to the book.
• Go to “Content Manager” and then click “Books” in the dropdown list.

• The list of book titles will appear. The book title “Muon Nen Nguoi” has
already been there.
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• Click the “View book content” under the book title and the summary. The
list of chapters will appear. The list is now empty.

• Click the “Record Edit” button near the upper right corner. A blank record
will appear.
Add the Foreword (“Loi Noi Dau”) to the book
This book starts with a foreword (“Loi Noi Dau”). We will treat it as a
chapter.

• Title box. Let’s fill in with “Loi Noi Dau”.
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• Description box. We will insert the text of the foreword here. Since this
foreword also contains a title, we will put it at the beginning of the text and
use a bold and bigger font.
• Choose Tree box. This box is showing “Muon Nen Nguoi”. Keep it as is.
• “No Link” box. Leave it as is because it is a chapter of the book.
• Click the “Add” button to finish adding the foreword.
Add the starting point of “Part I”
• Click the “New” button to start a new record.

• Title box. Fill in with “Phan I”.
• Description box. If there is an introduction or summary of Part I, fill it in
here. Otherwise, leave it blank.
• Choose Tree box. This box is showing “Muon Nen Nguoi”. Keep it as is.
• “No Link” box. Please check this box. This is the difference compared
with a chapter record. This record is the starting point of a part of the book.
• Author box. Fill in with the author of this part. It’s normally the author of
the book.
• Click the “Add” button. You’ve finished adding the starting point of Part I.
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Add Chapter 1 of Part I
• Click the “New” button to start a new record.

• Title box. Fill in with the chapter number or the chapter title. In this case,
fill in with “Chuong 1”.
• Description box. Insert the text of chapter 1 here.
• Choose Tree box. This box is showing “Muon Nen Nguoi”. You must click
the box and select “Phan I” in the dropdown list. This is important because
although this chapter is related to the book, it is directly related to “Phan I”.
• No Link box. Leave it as is, which means unchecked.
• “Author” box. Fill in with the author of the chapter or the book, otherwise
the author’s name will not be shown at the top of this chapter.
• Click the “Add” button to finish chapter 1.
• Before going any further, you’d better go to your website to check what you
have just done.
Check the website
• Click the category “Books”. Your web page will look similar to this.
WEBSITE ADMIN GUIDE – PART II (v. 2.5)

Page 281

• Click on “Muon Nen Nguoi”. The web page will look like this.

You will only see “Loi Noi Dau” and “Phan I”. You may haven’t seen
Chapter 1 yet and there is a small red button with a white plus (+) sign
before “Phan I”.
Click on the plus (+) sign, it will become the minus (-) sign. You will now
see chapter 1 underneath and it is shifted a little bit to the right. This is the
way to show that chapter 1 belongs to Part I.

Continue adding the rest of the book

WEBSITE ADMIN GUIDE – PART II (v. 2.5)

Page 282

• After checking to see if every thing is all right, continue to add the rest of
parts and chapters of the book.

You have finished the instructions for posting a book on the website.
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